User Tools

Site Tools


3d_modeling_animation:wow_weapons_armor_2

WoW Weapons & Armor, Part 1 - Helmets, Shoulders & Armor

By: Brixtan

Original article location

Please note that this is far more difficult than importing weapons. If you're just starting out, I highly suggest you get your feet wet with importing some weapons before moving on into armor sets.

I'm not going to hit all the details around manipulating models in Blender since they are covered in-depth in part 1, so if you have questions that are not directly addressed here, please refer back to the first part of this guide before PM'ing me.

1. Picking out an armor set in WMV

For this tutorial, we'll be using the Warrior Tier 12 armor:

First thing you need to do is open WMV. Select Characters, then select the human male model (since the textures sit more evenly on him). Next, select the chest, legs, gloves, and boots and pull up the molten giant piece that corresponds with each (for the boots, type in cracked obsidian stompers).

Now go to File → Export Textures → Export all to PNG. Find where you installed WMV to and open the export folder to find your textures:

2. Assembling the chest, gloves, and boot textures

Now, we need to overlay the chest textures, pants textures, and arm textures into a template that Torchlight recognizes. I used a destroyer vulture chest pattern from the assets as my template, so go ahead and make a copy of the original one and open it up in paintbrush (or whatever paint program you prefer - I use paintbrush): [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/vulture_chest.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/vulture_chest.png[/img][/url][/spoiler]

First we need to combine the chest textures, since they are exported as a top (chest_TU) and bottom (chest_TL). After you line them up vertically, we need to split them right down the middle: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor9.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor9.png[/img][/url][/spoiler]

Make a copy of each side and attach it to it's respective pair as such: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor10.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor10.png[/img][/url][/spoiler]

Next, we need to copy the sleeve and both portions of the pants (the upper portion LU, and the lower portion LL) - finally, cut off the excess at the bottom (it bleeds into what will be our texture for the boots and needs to be discarded) Note that the sleeves are not currently shown in the image below, but in the next image: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor12.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor12.png[/img][/url][/spoiler]

When you are finished, it should look like the picture below. One last step before we save the newly created chest.png - we need to make the non-textured area transparent, otherwise those sections not covered by the chest texture will show up as white on our model. I do this by opening the image in Photoshop, going to Image → Magic Extractor. This opens up a new window where you can paint the foreground image (your chest texture) with a stroke showing red, then the background with a blue stroke (these tools look like a brush with a + and - for foreground and background, respectively). After you are satisfied, click OK to finish, then save your image. For this tutorial, I'm saving the finished chest texture as moltenchest.png. Remember what you name your textures! You will have to cite these in your finished .dat files and in Blender for them to display correctly. The image should look like this: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor13.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor13.png[/img][/url][/spoiler]

Repeat this process for both your gloves and boots, again using a Torchlight glove/boot texture asset as your blueprint (make a copy, don't use the original!). Save your finished glove as moltengiantglove.png. Your gloves should look like the image below: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/moltengiantglove.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/moltengiantglove.png[/img][/url][/spoiler]

Save your boots as moltengiantboots.png. Your boots should look like this: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/moltengiantboot.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/moltengiantboot.png[/img][/url][/spoiler]

Step 3. Assembling your armor in Blender

Now the fun begins! Open up blender and go to File → Import → OGRE for Torchlight. Now you need to make your way to your Torchlight assets folder (pak.zip) and find a model you want to use. For this tutorial, I'm importing the hvyleather_set.MESH.xml. I've already made copies of all the different character meshes/skeletons and put them into separate folders (one for the destroyer, alchemist, and vanquisher). We're using the destroyer for this tutorial because I find him easier to work with when you're just starting out.

It's important to note that you always need a corresponding *.skeleton.xml for any *.mesh.xml so that the import script can merge the two together (the mesh of the character and the skeletal structure). Never import the *.skeleton.xml though or you'll get nasty errors. Your screen should look like this: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor15.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor15.png[/img][/url][/spoiler]

Yellow circles - I'm highlighting the various skeleton frames for you. They look like spines. Don't worry about these, you don't ever need to manipulate them. Blue boxes - here you need to rename your character meshes/skeleton. Pay attention to the red circle, you must leave that M at the end of your mesh name for this line only. Green boxes - these are your materials which will need to be renamed as well.

In the following image, you can see that we've now renamed the player mesh and skeleton as molten and moltenM respectively. Also, we've unlinked the boxes attached to each material to remove them. Next, we've renamed the materials to the following four (deleting any extra materials), molten/face, molten/gloves, molten/chest, molten/boots. [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor16.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor16.png[/img][/url][/spoiler]

Now we need to clean up our model by deleting the shoulder pads and helmet from the frame. You do this by making sure your model is actively selected (outlined in pink) by right clicking on him. Next, hit TAB to change the model to transparent with pink vertices. Next, press B once to change your cursor so that you can drag a box around vertices to select them. Once selected, hit DEL. A pop-up box will open - select vertices, and *poof* your vertices and any attached polygons are now deleted. Do this until your model looks like mine (this takes some time so be patient and don't rush): [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor19.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor19.png[/img][/url][/spoiler]

To texture the chest area, make sure your bottom right screen is sectioned off and is set to UV/Image Editor. Select Image → Open → and then find where you saved your moltenchest.png from earlier. Once open, click the thumbtack so it turns yellow, thus sticking the texture. [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor21.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor21.png[/img][/url][/spoiler]

Now, highlight the chest, arms, and legs of the model by selecting the vertices in the same manner that you did before when cleaning up the model. With your model actively selected, press B twice this time to get a circular cursor that you can use to paint over the areas you wish to select. They will turn pink. If you mess up an area, just press your middle mouse button (or mouse wheel like I do) and paint over areas to remove your selection. You'll need to adjust your model throughout this process, turning him around to get at all the angles. Simply right click, then move him around, then return to selecting the areas with your circular cursor. You're end result should look like mine: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor20.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor20.png[/img][/url][/spoiler]

Next, change your draw type (that little gold nugget looking circle in the image below) from solid to textured and your texture in the UV/Image Editor should appear on your model as shown:

You'll note that your texture is not nicely displayed across your model and there are some white gaps peeking through: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor24.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor24.png[/img][/url][/spoiler]

We need to manipulate the wire frame in our UV/Image Editor so that it lines up nicely with our model: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor23.png.html][img]http://s1180.photobucket.com/user/Brixtann/media/armor23.png[/img][/url][/spoiler]

First, in UV/Image Editor, go to View → Update Automatically and make sure this option is checked. This will update your texture on your model in real time as you adjust the wire frame in UV/Image Editor - very handy: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor25.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor25.png[/img][/url][/spoiler]

There isn't any real secret I can share for how to go about lining up your wire frame quickly and easily. You'll get better at it the more you practice. For now, I'm enclosing these screenshots so you can see the steps I took to get my textures lined up nicely on the model.

First, select the right half of the chest wire frame (you use the same commands here that you do when manipulating meshes): [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor26.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor26.png[/img][/url][/spoiler]

Next, invert it by pressing R twice making sure it's nice and flat. The yellow box shows your degrees, which you want to read 0.00 by -180: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor27.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor27.png[/img][/url][/spoiler]

Then press G to grab it and drag it over so that it lines up with the opposite side almost perfectly. Of note, if you select the matching vertices and press W, it should match them up together nicely (thanks Sixshot!) This will give you a nice mirrored image look on your model: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor28.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor28.png[/img][/url][/spoiler]

Adjust the textures for the sleeves and pants the same way as the chest, by selecting those corresponding sections of the wireframe. When you are satisfied, your model should look like this: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor29.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor29.png[/img][/url][/spoiler]

Before moving on to the gloves and boots, we need to assign this moltenchest.png texture to its respective material. See step 4 of Part 1 of the tutorial for how this is done if you've forgotten. When done, make sure your screen looks like the one below: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/material-1.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/material-1.png[/img][/url][/spoiler]

The orange box - this our chest material that we just finished adding the moltenchest.png texture too. You can tell that it has a texture assigned because there is a little face with moltenchest.png attached below the tex.001 (green check mark).

For the boots and gloves, you simply need to repeat the steps you did for the chest. Highlight the gloves, open your moltengiantglove.png texture, adjust the wireframe, apply it to the molten/gloves material. Rinse and repeat for the boots as well. When finished your model should look like this: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor32.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor32.png[/img][/url][/spoiler]

Step 4. Creating Helmet and Shoulder drop meshes

In the future, you can do step 4, which involves exporting of your helmets and shoulders from WMV, when you do the armor texture exporting at the beginning of this tutorial. I didn't mention it ahead of time because I didn't want to overwhelm folks with too much to-do work up front. If you are following this along completely, go ahead and save your current model work as something you'll remember! We'll be reopening the file later after we create helm and shoulder drop meshes to add them to the model.

Let me explain what I mean by creating drop meshes. Helmets and shoulder armor work a bit differently in Torchlight. You actually have to do two steps to get them into the game and functioning. The first is to create a drop mesh, that is, a visible helm or shoulder item that will drop on the ground when a monster dies (or when you drop the helm/shoulder on the ground yourself): [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/moltendrops.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/moltendrops.png[/img][/url][/spoiler]

In and of itself, these drop meshes will not display on your model. For that, you have to import your completed helm/shoulder drop mesh into our working model and join the two together. I'll be explaining that joining process later.

First, we need to take a quick detour from our current project and export the moltengiant helm and shoulders from WMV. Open up WMV and find the molten helm. Items → Objectcomponents → Head → helm_plate_raidwarrior_j_01_hum.m2 for the helm and Objectcomponents → Shoulders → rshoulder_plate_raidwarrior_j_01.m2

Export these the same way you would a weapon. Save the texture as moltenhelm.png and moltenshoulder.png respectively. Before closing WMV, if you want to take sceenshots of both to helmet/shoulder icons for later, go ahead. This is the same process for weapons in part 1 of the tutorial.

In your mod folder under Torchlight, you want to set up some additional folders as such: [code] Torchlight/mods/wow mod/media/wardrobe/destroyer/*[/code] The * is where you will place all your helmet, shoulder, glove, boot, and chest textures. This is also where our finished helmet and shoulder drop meshes will be stored, along with actual molten armor mesh/skeleton files and the *.material files (more on all those later).

Go ahead and place your moltenhelm.png texture in your mod folder, then open up blender. Import your molten giant helm, center it (if you want a centered helm when it drops in-game) and texture it. If you are unsure how to do this, refer back to part 1 of the weapons tutorial. It's the same process.

Unlike weapons, before you export your helm you must name it in the following pattern: name_helm_drop.mesh We'll name this molten_helm_drop.mesh, along with the material attached to it. Assign the textures and then export it: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor47.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor47.png[/img][/url][/spoiler]

Do the same for the shoulders, except when in blender, make a duplicate copy of the shoulder so you have two (for the drop mesh). Make sure the mesh is active, then press SHIFT + D to duplicate it. Name your mesh and material molten_shoulder_drop, following the same pattern as we did for the helm. Texture it the same you would a weapon, then export it: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor48.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor48.png[/img][/url][/spoiler]

In your mod folder, place the following files: [code]moltenhelm.png molten_helm_drop.material molten_helm_drop.mesh moltenshoulder.png molten_shoulder_drop.material molten_shoulder_drop.mesh [/code]

Let's go ahead and set up the rest of the .dat files for these drop meshes while we're at it. Your .dat file for your helmet and shoulders go in the following directory in your mod: [code]Torchlight/mods/wow mod/media/units/items/helms (for all helmets) Torchlight/mods/wow mod/media/units/items/shoulders (for all shoulders)[/code]

I named my molten helmet .dat file HELM_MOLTEN.DAT. Here is my exact .dat file for you to see: [spoiler=][code][UNIT] <STRING>BASEFILE:media\units\items\helms\base_helm _unique.dat <INTEGER>ARMOR_PHYSICAL:75 <INTEGER>LEVEL:100 <STRING>NAME:moltenh <INTEGER>RARITY:200 <INTEGER>ICON_SHEET:1 <STRING>ICON:moltenhelm_icon <STRING>RESOURCEDIRECTORY:media/wardrobe/destroyer <TRANSLATE>DISPLAYNAME:Molten Giant Helm <STRING>MESHFILE:molten_helm_drop <INTEGER>DEFENSE_REQUIRED:45 <INTEGER>STRENGTH_REQUIRED:65 <STRING>GAMBLER_ICON:leathercap <INTEGER>RARITY_HARDCORE:200 <INTEGER>MINLEVEL:75 <INTEGER>SPECIAL_AMR_MOD:100 <INTEGER>RARITY_AMR_MOD:200 <INTEGER>ARMOR_FIRE:25 <INTEGER>ARMORMIN:50 <INTEGER>ARMORMAX:50 <STRING>SET:MOLTEN <INTEGER>VALUE:500 <STRING>UNIT_GUID:5772301358675988960 [WARDROBE] <STRING>CLASS:DESTROYER <STRING>MESH:media/wardrobe/destroyer/molten.mesh <STRING>ITEM_MESH:media/wardrobe/destroyer/molten_helm_drop.mesh [/WARDROBE] [AFFIXES] <STRING>AFFIX:GEM_CHARCOAL_ARMOR <STRING>AFFIX:UNIQUE_ARMOR_PERCENT_BONUS <STRING>AFFIX:UNIQUE_BLOCK_CHANCE2 <STRING>AFFIX:UNIQUE_LUCK2 <STRING>AFFIX:UNIQUE_MAX_HP2 <STRING>AFFIX:UNIQUE_PERCENT_DAMAGE_TAKEN [/AFFIXES] [/UNIT][/code][/spoiler]

The important portions of this .dat file to point out are the following: [code]<STRING>NAME:moltenh This is the actual input for you to force drop the helm in-game with the console command

<STRING>MESHFILE:molten_helm_drop This is the actual drop mesh that you just finished making in blender.

<STRING>MESH:media/wardrobe/destroyer/molten.mesh This is eventually going to be our finished model mesh that we began work on. This tells Torchlight that the helm belongs to this specific mesh.

<STRING>ITEM_MESH:media/wardrobe/destroyer/molten_helm_drop.mesh again, the helm drop mesh. Seems a little redundant but make sure you have this point back to the helm drop.mesh [/code]

I named my molten shoulder .dat file SHOULDERS_MOLTEN.DAT. Here is my .dat file for you to copy/reference: [spoiler=][code][UNIT] <STRING>BASEFILE:media\units\items\shoulders\base_ shoulders_d_unique.dat <INTEGER>ICON_SHEET:1 <STRING>ICON:moltenshoulder_icon <STRING>RESOURCEDIRECTORY:media/wardrobe/destroyer <STRING>MESHFILE:molten_shoulder_drop <INTEGER>RARITY:200 <INTEGER>LEVEL:100 <INTEGER>ARMOR_PHYSICAL:75 <STRING>NAME:moltenp <TRANSLATE>DISPLAYNAME:Pauldrons of the Molten Giant <INTEGER>DEFENSE_REQUIRED:90 <INTEGER>STRENGTH_REQUIRED:15 <STRING>GAMBLER_ICON:heavyleathershoulders <INTEGER>RARITY_HARDCORE:200 <INTEGER>MINLEVEL:75 <INTEGER>ARMORMAX:40 <INTEGER>RARITY_AMR_MOD:200 <INTEGER>SPECIAL_AMR_MOD:100 <INTEGER>ARMOR_FIRE:25 <INTEGER>ARMORMIN:40 <STRING>SET:MOLTEN <INTEGER>VALUE:500 <STRING>UNIT_GUID:5772301362970956256 [WARDROBE] <STRING>CLASS:DESTROYER <STRING>MESH:media/wardrobe/destroyer/molten.mesh <STRING>ITEM_MESH:media/wardrobe/destroyer/molten_shoulder_drop.mesh [/WARDROBE] [AFFIXES] <STRING>AFFIX:UNIQUE_ARMOR_PERCENT_BONUS <STRING>AFFIX:UNIQUE_BLOCK_CHANCE2 <STRING>AFFIX:UNIQUE_LUCK2 <STRING>AFFIX:UNIQUE_MELEE_DAMAGE_BONUS <STRING>AFFIX:UNIQUE_THORNS [/AFFIXES] [/UNIT][/code][/spoiler]

After you have these set-up in your mod file ready to go, let's re-open our saved model in blender and pick up where we left off at the end of step 3.

Step 5. Merging the helmet to our model

Merging the helmet and shoulders takes awhile to explain, so I'm breaking them up into two separate steps for simplicity sake. With our work-in-progress model open in blender, import the molten_helm_drop.mesh from your mod folder where we saved it during the last step. File →Import → OGRE (not OGRE for torchlight!) → find your molten_helm_drop.mesh [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor30.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor30.png[/img][/url][/spoiler]

Note: the image above does not show a properly textured helmet. When I did this, I originally imported the initial helm mesh that I exported directly from WMV. You can do that as well if you skipped ahead and didn't make drop meshes for your helmet/shoulders from step 4 yet. Just know that you'll need to manually texture the helm/shoulders first before you go ahead and join them to the model. On the other hand, if you've been following along and imported your newly created molten_helm_drop.mesh, it should already display as textured when you switch to texture view in blender.

Next, rename your helm mesh to read molten/helmet, along with the sub-mesh, and the material (delete any extra materials that may be present, we only need 1) so that they all read molten/helmet. With the helmet still actively selected, you can remove excess vertices (called removing doubles) to help smooth it out slightly by pressing W, then selecting remove doubles from the drop-down menu. This is optional. See the image below for further details:

[spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor31.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor31.png[/img][/url][/spoiler]

Next, select both your helmet and your model so they are both active (highlighted in pink). Press CTRL +J to join the helmet to the model mesh. It will ask if you want to do this, select yes. Now you will see your molten/helmet is now merged beneath your moltenM model mesh: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor32.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor32.png[/img][/url][/spoiler]

Since you can no longer right-click on the newly joined helmet and manipulate it apart from the character model, you'll need to select the helm via a different method. Press TAB to change back to EDIT MODE, then press B like you did when we were cleaning up the model's excess armor at the beginning of the tutorial. Drag a box around the helm to select it, then press G to grab it. You can now drag it and position it on top of the models head: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor33.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor33.png[/img][/url][/spoiler]

Here are some keyboard shortcuts that you should commit to memory! [code]G - grabs the selected mesh R - rotates the selected mesh. Press R several times to change the field of rotation. B - change your cursor to select vertices S - scales a selected mesh larger or smaller SHIFT + D - duplicate a selected mesh M - mirrors a selected mesh, often used in combination with X, Y, or Z to move it along each axis.[/code]

Making sure your helmet mesh is still actively selected, press F9 to switch your bottom window to EDITING. Here is where we now anchor the helmet to specific bone groups in the model. This is how Torchlight will know where the helmet is suppose to be affixed to on your model when you pick it up in-game. Look at the following image and then read the directions, it's easier that way: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor34.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor34.png[/img][/url][/spoiler]

In the red box, change your vertex group to Bip01 Head and click assign. Next to that, the orange circle is showing you to click and make sure that your molten/helmet material (with texture!) is selected - click assign again.

To verify that you correctly anchored your helmet mesh to the model's head, switch the view to WEIGHT PAINT and look. Your helmet should be glowing red when you have the Bip01 Head vertex group actively selected below. If the helm is not glowing red, you didn't anchor it to the head correctly: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor35.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor35.png[/img][/url][/spoiler]

Step 6. Merging shoulders to our model

Thankfully, the initial steps here are the same with the helmet. You want to import your molten_shoulders_drop.mesh the same way you did with the helmet with one minor exception - delete one of the two pauldron meshes by selecting its vertices and pressing DEL. We'll recopy it later after merging it with the model.

After joining the shoulder mesh to the model, rename it Molten/shoulders, along with each material…same pattern as with the other materials underneath our moltenM mesh. Next, we need to join it to the shoulders. Throughout this, make sure you keep your shoulder mesh actively selected so that you can manipulate it apart from the model. We don't want to move the model or helmet anymore, just the shoulder.

I'm going to start lining up the shoulder on the right side first for this tutorial. Here's the image and what it all means: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor36.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor36.png[/img][/url][/spoiler]

There are actually 4 vertex groups you need to assign the shoulders to (2 for each arm); 1. Bip01 L UpperArm, shown by the yellow circle 2. Bip01 L Clavicle, shown by the blue circle 3. Bip01 R Clavicle, shown by the red circle 4. Bip01 R UpperArm, shown by the green circle

The process is the same for anchoring the shoulder as it was for the helmet, except you're going to assign the Vertex group Bip01 L UpperArm first (remember, this is from the models point of view, not yours…so Bip L is THEIR left arm - remember that), making sure you have the molten/shoulder material assigned as well. Then, switch vertex groups to Bip 01 L Clavicle and assign that one too. You won't get any confirmation that it's been done to more than 1 vertex group until you switch to WEIGHT PAINT mode to see if glows red or not. If you did it correctly, you should see this: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor37.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor37.png[/img][/url][/spoiler]

Next, we want to create a duplicate of the shoulder mesh. With the shoulder mesh actively selected, press SHIFT + D to duplicate it, then press M (to mirror it) followed by X (to move it along the x axis). Doing this will switch the active mesh from your current shoulder pauldron to the newly cloned one. Once you have it positioned nicely on the opposite shoulder, you need to assign the other 2 vertex groups to this newly created mesh: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor38.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor38.png[/img][/url][/spoiler]

Assign this newly cloned shoulder pauldron to the Bip01 R UpperArm and Bip01 R Clavicle. IMPORTANT! You need to remove Bip01 L UpperArm/Clavicle vertex groups from this shoulder pauldron since it was a direct copy of the previous one. When you copied it, you also copied its previously assigned vertex groups. This will result in some bad alignment of the shoulder pauldrons in-game. Check your work with WEIGHT PAINT mode and flip through the various vertex groups you assigned to make sure that their respective shoulder pauldron glows red appropriately! [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor40-1.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor40-1.png[/img][/url][/spoiler]

If you see this when you check the Bip01 L UpperArm (for example), then you forgot to remove it from the copied shoulder pauldron: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor39.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor39.png[/img][/url][/spoiler]

You'll know you did it correctly when it looks like this: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor42.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor42.png[/img][/url] [url=http://s1180.photobucket.com/user/Brixtann/media/armor41.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor41.png[/img][/url][/spoiler]

Here's my end result, along with my Outliner display for you to see how the finished mesh and materials should be organized. Pay no attention to how I named the prefixes (D_molten), I do that to help me identify various armor meshes by which class they were for: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor44.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor44.png[/img][/url][/spoiler]

Before you export your model, there is one last thing we need to do. Very simply, you need to attach your characters body.png (which can be found in the original Torchlight assets) to the molten/face material: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor46.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor46.png[/img][/url][/spoiler]

If you don't and try to export, you'll likely get a python error: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/armor45.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/armor45.png[/img][/url][/spoiler]

You want to export it in a similar fashion as you would for a weapon, changing the material name to molten.material (again, refer back to part 1 of the tutorial for questions with exporting).

Upon export, it should spit out molten.mesh, molten.material, and molten.skeleton. Place those here: [code]Torchlight/mods/wow mod/media/wardrobe/destroyer/*[/code]

Step 7. Folder organization and final DAT tweaks

Lastly, before booting into Torchlight and trying out the gear, we need to make some final .dat files for this armor set, mainly the chest, gloves, and boots.

Your chest piece goes here. Just save your .dat file as something like CHEST_MOLTEN.DAT and drop it in this folder: [code]Torchlight/mods/wow mod/media/units/items/armor/*[/code]

Here is my chest piece .dat file for you to use as a template: [spoiler][code][UNIT] <STRING>BASEFILE:media\units\items\armor\base_ches t_d_unique.dat <INTEGER>ICON_SHEET:1 <STRING>ICON:alchemist_body_07 <STRING>RESOURCEDIRECTORY:media/models/armor <STRING>MESHFILE:leatherpile <INTEGER>RARITY:200 <STRING>NAME:moltenchest <INTEGER>LEVEL:100 <INTEGER>ARMOR_PHYSICAL:75 <TRANSLATE>DISPLAYNAME:Molten Giant Breastplate <STRING>SET:MOLTEN <INTEGER>DEFENSE_REQUIRED:70 <INTEGER>STRENGTH_REQUIRED:50 <STRING>GAMBLER_ICON:heavyleathervest <INTEGER>VALUE:1500 <INTEGER>RARITY_HARDCORE:200 <INTEGER>MINLEVEL:75 <INTEGER>ARMOR_ICE:25 <INTEGER>ARMOR_FIRE:25 <STRING>UNIT_GUID:5772301341496119776 [WARDROBE] <STRING>CLASS:DESTROYER <STRING>TEXTURE:media/wardrobe/destroyer/moltenchest.png <STRING>MESH:media/wardrobe/destroyer/molten.mesh [/WARDROBE] [AFFIXES] <STRING>AFFIX:GEM_CHARCOAL_ARMOR <STRING>AFFIX:UNIQUE_ARMOR_BONUS9 <STRING>AFFIX:UNIQUE_ARMOR_PERCENT_BONUS7 <STRING>AFFIX:UNIQUE_BLOCK_CHANCE9 <STRING>AFFIX:UNIQUE_DEFENSE_BONUS3 <STRING>AFFIX:UNIQUE_LIFE_STEAL5 <STRING>AFFIX:UNIQUE_LUCK9 <STRING>AFFIX:UNIQUE_MAX_HP9 <STRING>AFFIX:UNIQUE_MAX_MANA9 <STRING>AFFIX:UNIQUE_MISSILE_REFLECT5 <STRING>AFFIX:UNIQUE_PERCENT_DAMAGE_TAKEN5 <STRING>AFFIX:UNIQUE_PET_HEALTH7 [/AFFIXES] [/UNIT][/code][/spoiler]

The most important strings here are: [code]<STRING>TEXTURE:media/wardrobe/destroyer/moltenchest.png This points to where you saved the moltenchest.png texture we assembled at the very beginning!

<STRING>MESH:media/wardrobe/destroyer/molten.mesh This points to our newly finished character mesh, which we saved as molten.mesh and placed in that folder tree shown.[/code]

Your boots .dat file goes here: [code]Torchlight/mods/wow mod/media/units/items/boots/*[/code]

Here my BOOTS_MOLTEN.DAT: [spoiler][code][UNIT] <STRING>BASEFILE:media\units\items\boots\base_boot s_d_unique.dat <INTEGER>LEVEL:100 <INTEGER>RARITY:200 <INTEGER>ARMOR_PHYSICAL:100 <STRING>NAME:moltenboots <STRING>ICON:vanq_assassin_boots <STRING>RESOURCEDIRECTORY:media/models/armor <STRING>MESHFILE:booticon <TRANSLATE>DISPLAYNAME:Molten Giant Sabatons <INTEGER>DEFENSE_REQUIRED:20 <INTEGER>STRENGTH_REQUIRED:100 <STRING>GAMBLER_ICON:heavyleatherboots <STRING>SET:MOLTEN <INTEGER>VALUE:500 <INTEGER>RARITY_HARDCORE:200 <INTEGER>MINLEVEL:75 <STRING>UNIT_GUID:5772301350086054368 [WARDROBE] <STRING>CLASS:DESTROYER <STRING>TEXTURE:media/wardrobe/destroyer/moltengiantboot.png <STRING>MESH:media/wardrobe/destroyer/molten.mesh [/WARDROBE] [AFFIXES] <STRING>AFFIX:UNIQUE_LUCK2 <STRING>AFFIX:UNIQUE_PERCENT_DAMAGE_TAKEN <STRING>AFFIX:UNIQUE_PET_TOWN_RETURN3 <STRING>AFFIX:UNIQUE_PET_VELOCITY <STRING>AFFIX:UNIQUE_THORNS [/AFFIXES] [/UNIT][/code][/spoiler]

Your gloves .dat file goes here: [code]Torchlight/mods/wow mod/media/units/items/gloves/*[/code]

This is my GLOVES_MOLTEN.DAT file: [spoiler][code][UNIT] <STRING>BASEFILE:media\units\items\gloves\base_glo ves_d_unique.dat <INTEGER>RARITY:200 <STRING>NAME:molteng <INTEGER>ICON_SHEET:1 <STRING>ICON:vanq_heavy_leather_gloves <STRING>RESOURCEDIRECTORY:media/models/armor <STRING>MESHFILE:gloves <INTEGER>ARMOR_PHYSICAL:100 <TRANSLATE>DISPLAYNAME:Gloves of the Molten Giant <STRING>SET:MOLTEN <INTEGER>DEFENSE_REQUIRED:45 <INTEGER>STRENGTH_REQUIRED:55 <STRING>GAMBLER_ICON:scalegloves <INTEGER>LEVEL:100 <INTEGER>VALUE:500 <INTEGER>RARITY_HARDCORE:200 <INTEGER>MINLEVEL:75 <STRING>UNIT_GUID:5772301354381021664 [WARDROBE] <STRING>CLASS:DESTROYER <STRING>TEXTURE:media/wardrobe/destroyer/moltengiantglove.png <STRING>MESH:media/wardrobe/destroyer/molten.mesh [/WARDROBE] [AFFIXES] <STRING>AFFIX:UNIQUE_ATTACK_SPEED2 <STRING>AFFIX:UNIQUE_CRIT_CHANCE2 <STRING>AFFIX:UNIQUE_CRITICAL_DAMAGE_BONUS <STRING>AFFIX:UNIQUE_LUCK2 <STRING>AFFIX:UNIQUE_MELEE_DAMAGE_BONUS [/AFFIXES] [/UNIT][/code][/spoiler]

Finally, double check that your… [code]Torchlight/mods/wow mod/media/wardrobe/destroyer/*[/code] …folder contains all the files that we created in this tutorial. Here are mine highlighted to show you: [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/FINALFOLDERLAYOUT.png.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/FINALFOLDERLAYOUT.png[/img][/url][/spoiler]

:D Here is our newly clad Destroyer in Molten Giant Tier 12 raid gear! :D [spoiler][url=http://s1180.photobucket.com/user/Brixtann/media/2012-03-02_00001.jpg.html][img]http://i1180.photobucket.com/albums/x418/Brixtann/2012-03-02_00001.jpg[/img][/url][/spoiler]

Have fun and go mod something![/quote]

3d_modeling_animation/wow_weapons_armor_2.txt · Last modified: 2019/08/18 09:16 by anarch16sync