collapse

* Important


The forum and all threads have been locked, but are still available for browsing.  There is more information about this here.


The

Is still open for article contributions.

Author Topic: Shields with new base file disappears in GUTS  (Read 4279 times)

Offline Wolven

  • Operator
  • Unique
  • *
  • Posts: 338
  • Country: no
    • status mod
    • View Profile
  • Mood: mood smiley
Shields with new base file disappears in GUTS
« on: September 01, 2014, 10:16:02 am »
I'm experimenting with creating some shields, which have a new base file. The new shields work fine and I can spawn them in the editor game, but any new shield using a different base file than vanilla will not be displayed in the Item Editor list. If I change it back to use the standard base file it appears in the list again.

My base file, located in: media\units\items\shields\
Code: [Select]
[UNIT]
<STRING>CREATEAS:EQUIPMENT
<STRING>UNITTYPE:NORMAL SHIELD
<INTEGER>ARMORMIN:40
<INTEGER>ARMORMAX:40
<INTEGER>VALUE:75
<BOOL>DONTCREATE:true
<STRING>FALL_SOUND:Item Fall
<STRING>TAKE_SOUND:MetalGet
<STRING>LAND_SOUND:MetalDrop
<INTEGER>BLOCK_CHANCE:7
<STRING>GAMBLER_ICON:icons__shield01
<INTEGER>RARITY_AMR_MOD:100
<INTEGER>DEFENSE_REQUIRED:45
<INTEGER>DEXTERITY_REQUIRED:0
<INTEGER>MAGIC_REQUIRED:0
<INTEGER>STRENGTH_REQUIRED:30
<STRING>NAME:tla_base_shield
<STRING>UNIT_GUID:-2030796240000217279
[EFFECT]
<STRING>NAME:40
<STRING>ACTIVATION:PASSIVE
<STRING>TYPE:PERCENT KNOCK BACK RESISTANCE
<BOOL>NONMAGICAL:true
<FLOAT>RESISTANCE:40
[/EFFECT]
[/UNIT]

My new shield, also located in: media\units\items\shields\
Code: [Select]
[UNIT]
<STRING>BASEFILE:media\units\items\shields\tla_base_shield.dat
<INTEGER>DAMAGE_PHYSICAL:0
<TRANSLATE>DISPLAYNAME:Spellblade Shield
<STRING>ICON:icon_weapon_shield07
<INTEGER>LEVEL:23
<STRING>MESHFILE:shield07
<STRING>NAME:tla_spellblade_shield_start
<INTEGER>RARITY:100
<STRING>RESOURCEDIRECTORY:media/models/weapons/_Shields
<INTEGER>STRENGTH_REQUIRED:45
<INTEGER>DEFENSE_REQUIRED:45
<INTEGER>SOCKETS:2
<INTEGER>MAX_SOCKETS:2
<STRING>UNIT_GUID:-2458686679345536827
<INTEGER>ARMOR_PHYSICAL:100
[/UNIT]

Everything seems to be in order, as far as I can tell, and like I said. The shield can be spawned and used in the editor.

Has anyone else noticed any similar issues to this?

Offline RnF

  • Developer
  • Rare
  • *
  • Posts: 234
  • Country: us
    • status idle
    • View Profile
  • Mood: mood smiley
Re: Shields with new base file disappears in GUTS
« Reply #1 on: September 01, 2014, 02:18:55 pm »
This is a common bug.  If you add the UNITTYPE to the file it will reappear.  The majority of my LAO files can't be seen in GUTS because of this issue.

Offline Wolven

  • Operator
  • Unique
  • *
  • Posts: 338
  • Country: no
    • status mod
    • View Profile
  • Mood: mood smiley
Re: Shields with new base file disappears in GUTS
« Reply #2 on: September 01, 2014, 05:02:17 pm »
OK, thank you, RnF. A very annoying bug...  >:(

Tags: shield base 
 

Our host and sponsor

* Quick Search


* Mod Boards Activity

* Popular Topics