News: Go to the front page portal to create a Torchmodders account | Visit the wiki!
June 20, 2019, 03:45:59 PM
collapse

*
Information

Please contribute to our


Sign up for a forum account at the Front Page. | Remember to Tag your posts.
Having problems logging in to the forums? Go the front page, log out and back in again.

Author Topic: Need help on an issue with no help anywhere  (Read 2864 times)

Offline Shawn

  • Common
  • *
  • Posts: 2
    • View Profile
Need help on an issue with no help anywhere
« on: January 18, 2019, 12:23:53 AM »
Alright so I'm having a very big problem and I hope these forums arent dead enough that no one can help me. When I made a new ability, most of them work fine. However a couple I've made have a very frustrating and at the moment very frustrating 'bug', wherein for no particular reason, when they are upgraded, they trigger some part of their particle effects. I have no idea whats causing this: the ability, the animation, the event types, the particles themselves, the layout timeline, I can't even find any significant difference between a pre-existing ability and the one I made to pinpoint a problem. I don't know where else to go for help.

Update 1: I finally found what property controlled this: Start on load, however a different problem arises in the fact that the particle is not playing normally in the animation i've chosen, which I suppose hopefully will be fixed by switching or editing, perhaps the ability has no event_trigger tag. Hopefully any other beginning modder finds this and solves their issue too
« Last Edit: January 18, 2019, 12:37:52 AM by Shawn »

Offline Korzeam

  • Rare
  • *
  • Posts: 167
  • Country: fr
    • status idle
    • View Profile
  • Mood: mood smiley
Re: Need help on an issue with no help anywhere
« Reply #1 on: January 18, 2019, 05:04:38 AM »
What kind of skills is concerned with your issue ?
If it is a skill that involves movement it can be a particle attachement issue.

Offline Shawn

  • Common
  • *
  • Posts: 2
    • View Profile
Re: Need help on an issue with no help anywhere
« Reply #2 on: January 19, 2019, 02:24:19 AM »
What kind of skills is concerned with your issue ?
If it is a skill that involves movement it can be a particle attachement issue.

Essentially, when the particle's option for "start on load" was set to true, the particle would play whenever I added a point to the skill. Turning this off solved the issue perfectly. For reference, I made a wave ability not unlike tremor, and when I plussed the ability, the wave particle would play. I thought there was another issue when the ability itself never played the particle, but soon realized the animation I used simply didn't use any "hit" key frames. I was freaking out a bit when I made this post, but now it's all but resolved thankfully. It's tough when trying to search for an issue you're haviing yields no results until you stumble across the fix. I'm trying my hand at missle creation next so that ought to be a challenge

Offline Korzeam

  • Rare
  • *
  • Posts: 167
  • Country: fr
    • status idle
    • View Profile
  • Mood: mood smiley
Re: Need help on an issue with no help anywhere
« Reply #3 on: January 19, 2019, 05:47:26 AM »
It's good if you have solved your problems.  ;)

For the "start on load" issue, it has indeed an effect when you test your class in GUTS but I don't think it has the same behavior in game.
So it was not a big deal.

Offline Phanjam

  • Operator
  • Legendary
  • *
  • Posts: 2666
  • Country: ph
    • status ready
    • View Profile
  • Mood: mood angel
Re: Need help on an issue with no help anywhere
« Reply #4 on: February 11, 2019, 12:00:02 PM »
hey @Shawn sorry if it felt like no one was around to help! it's a bit of a hassle but you can try cross-posting in the torchmodder's discord (link is right underneath our right-panel shoutbox window) since there's almost always ppl there too.

but im glad to hear you got the issues solved ;) speaking of animations, you may already know this but i'll go ahead and mention you can also attach particle layouts directly to an animation via
Code: [Select]
[KEY]
<STRING>LAYOUT:
[/KEY]
lines of code :)



Offline lolesch

  • Rare
  • *
  • Posts: 192
  • Country: de
    • status ready
    • View Profile
  • Mood: mood rolleyes
Re: Need help on an issue with no help anywhere
« Reply #5 on: March 10, 2019, 04:45:10 PM »
For further investigation it is helpful to post the full code of your files. When I started to mod skills I had a hard time too but with each problem I learned to use the system more and more. Copying a vanilla skill and changing it to whatever you desire may prevent some errors of setting up all by yourself.

Have you fixed all your problems now?
some projects in progress

Tags:
 

* Quick Search


* Member Information

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Mod Boards Activity

* Who's Online

  • Dot Guests: 1
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Calendar

June 2019
Sun Mon Tue Wed Thu Fri Sat
1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 [20] 21 22
23 24 25 26 27 28 29
30

No calendar events were found.

* Recent Topics

[Stats], [Effects] & [Charges] by Rhythmier
[Today at 06:01:03 AM]


Lightbringer Mod (Paladin) by Rhythmier
[Today at 05:04:55 AM]


Need Help: a problem in GUTS by Sch123
[June 19, 2019, 11:41:00 PM]


A new beginning by Phanjam
[June 19, 2019, 02:04:50 PM]


New props & ideas for "The Dark Palace" by Phanjam
[June 18, 2019, 02:22:33 AM]


Hosting for 2019 by Wolven
[June 17, 2019, 08:50:11 PM]


Darkened TL2 UI (Re-texture Mod) by Rhythmier
[June 12, 2019, 08:27:13 AM]


FEP+ by Sch123
[June 11, 2019, 10:42:57 PM]


Variant Classes Bug Reports by Viz
[June 11, 2019, 01:18:21 PM]


Charge Domination % by Phanjam
[June 08, 2019, 02:30:49 PM]


Triggerable Weapons by Phanjam
[June 04, 2019, 12:25:05 PM]


FEP+ April 2019 Update by steffire3
[June 02, 2019, 07:40:37 AM]


Destroyer Rebalance by Phanjam
[May 25, 2019, 02:28:58 AM]


Skills Expansion: Bugs Report & Ideas by Sch123
[May 16, 2019, 10:54:27 AM]


[Help Request] Putting Custom Dungeons Into Vanilla Zones by Phanjam
[May 09, 2019, 02:19:19 AM]

* Popular Topics